Back to Knowledge Base

For best experience, we recommend using the latest versions of the following browsers.

Please note CryptoTradeSmith does not support Beta browsers.

 Microsoft Internet Explorer: Download the latest version of Internet Explorer.

 Safari: Download the latest version of Safari

 Firefox: Download the latest version of Firefox.

 Google Chrome: Download the latest version of Google Chrome.

Please note that by downloading, you acknowledge that these are third party software.

TradeSmith is not responsible for any consequences resulting out of installation or usage of third party software, including cryptocurrency wallets.